Issue loading Reviews from the nav bar
Incident Report for Lattice
Resolved
This issue has now been resolved.
Posted Mar 21, 2023 - 07:56 PDT
Identified
We've identified the cause of this issue, and are implementing a fix.
Posted Mar 21, 2023 - 07:03 PDT
Investigating
We are currently investigating an issue with accessing Reviews from the left navigation bar.
Posted Mar 21, 2023 - 06:59 PDT
This incident affected: Lattice Application.