Error Downloading Review Packets
Incident Report for Lattice
Resolved
This incident has been resolved. Please refresh your page if you are still encountering an issue when trying to download a review packet.
Posted Mar 22, 2023 - 11:11 PDT
Update
We are still working on implementing a fix.
Posted Mar 22, 2023 - 11:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2023 - 10:51 PDT
Investigating
Users are experiencing errors when trying to download review packets. Our team is actively working to identify the underlying root cause and implement a solution.
Posted Mar 22, 2023 - 10:43 PDT
This incident affected: Lattice Application.