Issue with upstream provider on lattice.com

Incident Report for Lattice

Resolved

The incident is resolved.
Posted Jun 03, 2025 - 12:25 PDT

Monitoring

Our upstream provider has resolved the issue with Lattice's public website at https://lattice.com/

We do not anticipate any further disruptions but are continuing to monitor site performance.
Posted Jun 03, 2025 - 10:04 PDT

Investigating

Our upstream provider is currently experiencing an issue which is affecting Lattice's public website at https://lattice.com/

We will resolve this incident once we have received confirmation the issue has been resolved from our upstream provider.

The Lattice application is unaffected by this outage and the Lattice application's functionality remains stable.
Posted Jun 03, 2025 - 09:26 PDT
This incident affected: Lattice Homepage.