Lattice Service Disruption: Error in Reviews admin panel

Incident Report for Lattice

Resolved

A fix has been implemented and the incident has been resolved.
Posted Sep 27, 2023 - 14:23 PDT

Investigating

Admins are experiencing an error when navigating to the Progress and Reviewers section of active review cycles in the admin panel.

Our team is actively working to identify the underlying root cause and implement a solution.
Posted Sep 27, 2023 - 13:55 PDT
This incident affected: Lattice Application.