Issues with the Outlook calendar integration

Incident Report for Lattice

Resolved

This incident has been resolved. Lattice users can establish new Outlook calendar connections for 1:1 meetings, and pre-existing Outlook calendar connections are present and functional.
Posted Sep 08, 2025 - 08:06 PDT

Update

Lattice has restored the ability to establish new connections to an Outlook calendar for 1:1 meetings. Our team is continuing to work on restoring all previous Outlook calendar connections.
Posted Sep 08, 2025 - 06:47 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2025 - 03:25 PDT

Investigating

Our Engineering Team are currently investigating an issue around the Outlook calendar integration.
Posted Sep 08, 2025 - 02:09 PDT
This incident affected: Lattice Application.