Updating Databases

Scheduled for Sep 18, 18:00 - 20:30 PDT

Update

Scheduled maintenance will begin today at 6:00PM Pacific Daylight Time for approximately 2.5 hours. Lattice will be operational during this time, but users may experience slow response times. Lattice will return to full functionality after maintenance has been completed.
Posted Sep 17, 2025 - 11:08 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 17, 2025 - 11:06 PDT

Scheduled

Scheduled maintenance will begin today at 6:00PM Pacific Daylight Time for approximately 2.5 hours. Lattice will be operational during this time, but users may experience slow response times. Lattice will return to full functionality after maintenance has been completed.
Posted Sep 15, 2025 - 15:14 PDT
This scheduled maintenance affects: Lattice Application.