Issue with upstream provider

Incident Report for Lattice

Resolved

Cloudflare, an upstream provider, is currently experiencing an issue. This temporarily affected Lattice site performance and caused connection timeout errors for some users.

Lattice performance has returned to normal. Our Engineering Team is continuing to monitor the situation.
Posted Jul 24, 2026 - 04:00 PDT