Issue with downstream providers

Incident Report for Lattice

Resolved

Full access to live chat with Customer Care has been restored. Our Engineering Team will be continuing to investigate the possible effects of the downtime on our services.
Posted Oct 20, 2025 - 06:26 PDT

Monitoring

We're aware of AWS outages that are affecting many third party services. While Lattice isn't directly affected, some of our downstream providers are experiencing downtime, including our support platform for live chat. Our Engineering Team is actively investigating the effects of this downtime on our services.

For immediate support, please email customercare@lattice.com.
Posted Oct 20, 2025 - 03:11 PDT
This incident affected: Lattice Application.