Email Notifications Delayed
Incident Report for Lattice
Resolved
This incident is resolved. We anticipate continued prompt delivery of all email notifications.
Posted Feb 19, 2024 - 11:13 PST
Monitoring
All delayed email notifications are being sent out to users. Our team is continuing to monitor to make sure email notifications continue to send as expected.
Posted Feb 19, 2024 - 11:02 PST
Investigating
Some customers are experiencing delays in notifications to their email inbox. Our team is investigating the cause of this delay and working to restore prompt email delivery.
Posted Feb 19, 2024 - 10:50 PST
This incident affected: Lattice Application.