Lattice Service Disruption: Data may appear out of sync
Incident Report for Lattice
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 11:21 PDT
Identified
Users may experience an issue where data does not appear to be updated after changes are made. Our engineering has identified the issue and is working on implementing a fix.
Posted Mar 20, 2023 - 09:15 PDT
This incident affected: Lattice Application.