Lattice notifications delayed

Incident Report for Lattice

Resolved

Notifications are now being re-sent for any notifications affected. Our Engineering Team have identified that this was caused by the outages with Cloudflare and our email service provider.
Posted Nov 18, 2025 - 07:06 PST

Investigating

We're aware of delays in the sending of Lattice notifications via email, Teams, and Slack. Our Engineering Team are investigating the root cause behind these delays, and will be re-sending any delayed notifications.
Posted Nov 18, 2025 - 06:24 PST
This incident affected: Lattice Application.