Live Chat Interruption
Incident Report for Lattice
Resolved
Our live chat service provider has confirmed that the issue is resolved. Full access to live chat with Customer Care should now be restored.
Posted May 02, 2024 - 07:49 PDT
Investigating
Our live chat service provider is currently experiencing an interruption that may prevent chatting with Customer Care. For immediate support, please email customercare@lattice.com.
Posted May 02, 2024 - 07:00 PDT